Câblage RS-CNC

Voici les schémas de câblage simplifiés pour la RS-CNC

1- Schéma de puissance :

Les couleurs des fils des moteurs pas à pas peuvent varier d’un constructeur à l’autre, vérifier la documentation de vos moteurs afin de connaitre à quelle couleur correspondent les fils A+, A-, B+,B-

Note: Pour plus de sécurité, vous pouvez relier les règles alu du châssis (celles où sont intégrées la prise secteur et le bouton d’arrêt d’urgence) à la terre.

2- Schémas de commande :

 

Pour le branchement du Nunchuk, comme il n’y a pas de détrompeur, regardez dans la prise, vous avez un coté avec 3 contacts, et l’autre avec deux contacts, ils doivent bien évidement correspondre avec les pistes de la prise du shield.

Note: Le nunchuk doit être branché pour que la machine fonctionne normalement.

Pensez avant la première mise sous tension à vérifier que votre alimentation est réglée sur le voltage de votre pays !

Réglage des drivers TB6600

  • Reportez vous au tableau imprimé à même le driver pour connaitre la position adéquat des petits leviers sur le coté du driver.
  • Réglez les steps en 1/4 de pas (aucune différence de résultat avec un réglage en 1/16)
  • Réglez l’ampérage en fonction de la fiche technique de vos moteurs

Vérifiez plusieurs fois vos branchements avant la première mise sous tension, puis direction la page firmwares

24 commentaires sur “Câblage RS-CNC”

  1. Bonjour Gérard,
    J’ai eu le même problème il faut brancher le TFT sur aux1 et l’alimenter en 24v. ça ne fonctionne pas avec juste l’arduino raccordé sur le pc en usb.

    bonne journée
    Stéphane

  2. In the TB6600 driver I don’t see the option for 1/4 steps. It only shows options like 1-200, 2/A-400, 2/B-400… which one is correct for 1/4 steps. Thanks!

      1. bonjour,
        désolé si il y a un doublon de message je sais pas si le 1er est posté,

        j’essaye d’installer le firmware mais étant sur l’anceinne version tous mes drivers sont configurés pour l’ancienne
        que faut modifier pour ne pas toucher les réglages de mes drivers ? car il ne fonctionnent pas en 1/4

        merci d’avance

        1. Hello,
          Dans configuration.h il faut trouver les lignes:
          #define XAXIS_STEPS_PER_MM 240
          #define YAXIS_STEPS_PER_MM 240
          #define ZAXIS_STEPS_PER_MM 1600
          et changer les valeurs
          Romain

  3. Hi RoMaker,

    I bought the CNC shield from your shop and I have one problem: on the pins marked with 5V I don’t have 5V unless I connect arduino to an USB source (PC or other source), any idea how to fix this ?

    Best Regards,
    Stefan

    1. Hi,
      If you don’t have 5v at the 5v pin, please check your arduino mega 2560 board !
      5V pin on the shield uses the 5v power from mega2560 regulator.
      The 5v regulator on the shield is used to power only the tft, not the 5v pin.

      1. On your wiring diagram the gnd pins (ENA- / DIR- / PUL-) are connected on -5V on that pin on shield, and the drivers don’t work, if I connect an usb cable to arduino then all it’s ok, can I take than GND from another source ?

        1. Hi, Ena-, Dir-, Pul- of the TB6600 have to be connected on the GND pin of the shield.
          If you still have issue, please create a post on the forum (international section) with pictures of your wiring.
          Romain

  4. Salut, je projette d’utiliser un spindle, mais du coup pour le contrôle de la vitesse, ça se passe comment ? Le câblage diffère ? le shield et le firmware n’ont pas à être adapté ?
    Bonne journée 🙂

    1. Bonjour,
      Tout dépend du spindle utilisé ! Est-ce un spindle avec un potentiomètre ou avec un module de gestion de la vitesse PWM ?
      Romain

      1. Bonjour,
        La réponse à la question « avec un module de gestion de la vitesse PWM » (0-10V) m’intéresse. Cela est possible avec la shield ?

  5. Je vais prendre celui que tu as listé avec les pièces, il devrait être largement suffisant ^^ je ne sais pas encore si je prendrais sur AliExpress ou banggood.

  6. Bonjour,

    Je suis en cours de programmation de la carte Mega, tout est OK mais je voudrais vérifier l’avance en mm sur X,Y,Z. Dans « Configuration.h » de REPETIER FW je ne trouve pas les lignes concernées.

    Je suis en 1/8 de pas sur les drivers. Dons si mon calcul est bon cela doit faire moteur 200 pas et poulies préconisées (60 et 20 dents) donc rapport 1/3.

    X et Y = 400
    Z = 800

    A moins que les valeurs soient indiquées d’origine auquel cas, je n’y touche pas.

    Merci

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *