Candle issue

Avatar du membre
HTheatre
Messages : 4340
Enregistré le : 31 mars 2019 08:21
Localisation : Rivesaltes

Re: Candle issue

Message par HTheatre »

Hi sohejl,
sohejl a écrit : 14 juil. 2021 21:56 The other question, I wanted to try romains hint regarding baud rates. I looked in the config.h of the TFT firmware but I cannot identify where to change it.
For the TFT's firmware, open it with ARDUINO IDE and make a search on "115200" in the grbl_controller_esp32 file, the information your are looking for is in this file and not in config.h file. Be careful, you have to modify the baud rate at 2 places.

For the Grbl's firmware (for v1.0 or v1.5 Grbl boards kit), open it with Atollic True Studio, and make the same search than above in config.h file. You should find the following lines :

89 // Serial baud rate
90 #define BAUD_RATE 115200


Make sure to set the same baud rate into the 2 firmwares (ESP-32 + STM-32), else the 2 chips won't be able to communicate together.

I am sorry I do not have the answers to your other questions.

See ya,
Avatar du membre
sohejl
Messages : 18
Enregistré le : 05 juil. 2019 13:47
Localisation : Germany

Re: Candle issue

Message par sohejl »

Hi htheatr,

thanks for the advice, I will follow up when I have made the changes, might there be any experience whether which baudrate might work properly? What might be the downside to change the baudrate to a lower value, anything which I need take into account when sending cnc commands directly via eg candle?
Should I go for the lower end with 9600 directly or is it better to change step by step and try 57600 first and so on?

Thanks in advance for the support!
Best Regards
Soli
Avatar du membre
HTheatre
Messages : 4340
Enregistré le : 31 mars 2019 08:21
Localisation : Rivesaltes

Re: Candle issue

Message par HTheatre »

Hi sohejl,

I'm sorry I don't know Candle. I never used it. For the baud rate I suggest to decrease its value step by step. With a to low baud rate value, issues of Gcode's commands transmission may occur.

See ya,
Avatar du membre
sohejl
Messages : 18
Enregistré le : 05 juil. 2019 13:47
Localisation : Germany

Re: Candle issue

Message par sohejl »

It seems so easy :arrow:

I tried to flash both STM32 and ESP32 with the adapted fw with a baud rate of 57600 and 38400, for which I changed the baud rates implemented in the

- STM32 GRBL fw / config.h
89 // Serial baud rate
90 #define BAUD_RATE 57600

- ESP32 TFT fw / grbl_controller_esp32
192 Serial.begin(57600); // init UART for debug and for Gcode passthrough via USB PC

first no luck, then I found another Serial.begin in com.cpp, which seems to be the com baudrate for the communication between STM32 and the ESP32 and changed this also.

- ESP TFT fw / com.cpp
905 Serial2.begin(57600, SERIAL_8N1, SERIAL2_RXPIN, SERIAL2_TXPIN); // initialise le port série vers grbl

Now it's working again as expected - whether or not thats the solution will to been seen. I report back, when I had the time to test properly with my pcb stuff.
Best Regards
Soli
Avatar du membre
sohejl
Messages : 18
Enregistré le : 05 juil. 2019 13:47
Localisation : Germany

Re: Candle issue

Message par sohejl »

First test of one little Project for my new datalogger pcb went without any incident and/or problem. So it's looking really good, since the hole pcb took more than 2 hours to make. It seems changing the baud rate to 57600 was, at least for me, the solution for now... I really hope :lol:

So for now, thanks again for the support and helpfull advice!
Regards
Soli
Best Regards
Soli
Avatar du membre
HTheatre
Messages : 4340
Enregistré le : 31 mars 2019 08:21
Localisation : Rivesaltes

Re: Candle issue

Message par HTheatre »

We are glad to read all seem to work fine for you.

Enjoy your CNC !

See ya,
Répondre